Announcement

Collapse
No announcement yet.

TJ no umph cuts out at 2800-3k

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • TJ no umph cuts out at 2800-3k

    03 Wrangler X 6cyl, I bought from a guy I work with. It sat up for years and then my buddy drug it down to his place. I knew he was fighting an issue but wasn't sure how bad. So, I bought it and drove it home. Feels like it is running on 4cyl. After driving it a while to the house I noticed in 2cnd/3rd it would cut out like hitting a rev limiter. He has changed the fuel pump (starts perfect), swapped out the coil pack and then took it back (no change), CPS, and I know he swapped out the whole side evaporative canister thingy that starts in the back and goes forward. Oh and one O2 sensor. So, all signs pointed to exhaust in my mind. Nope. I left the cats hanging by one screw and no change other then the noise. I plan on building another low riding Willys clone, but not until I square this away. The price was decent so I can part it out if I need too. Never had one do this and you guys know I have owned like 7 of these. Oh and 166k miles, so not too bad. Rock solid idle at about 800 rpm but when you hit the gas it does shake.

  • #2
    Injectors 3 and 4 no bueno. Will be digging into this a little more tomorrow.

    Comment


    • #3

      Comment


      • #4
        I know right! I sent the computer to Wranglerfx in Florida. I tested the injector wiring and the 12v constant was good but no pulse on the grounds.

        Comment


        • #5
          They fixing the computer?
          97’ TJ on 37’s with 4 Angry Squirrels
          2020 F250 Powerstroke Tow Pig

          Comment


          • #6
            Yeah they have a simulator they hook it up to and if it fails and they can fix it 150.00 plus the ride. If they can't fix it they figured out some newer computer that works they reprogramed for 500.00 or so, and if there is nothing wrong they send it back and you just pay the shipping. They got started fixing 05-06 computers. Only other thing could be the harness but I didn't see anything obvious. He said this was a fairly common issue.

            Comment


            • #7
              Good to know. Mine is going on 26 years
              97’ TJ on 37’s with 4 Angry Squirrels
              2020 F250 Powerstroke Tow Pig

              Comment


              • #8
                He actual said today that my computer hardly ever fails but the 05-06 have a some issues. He sent me a video of mine running on the simulator. Everything was firing perfectly, it was kind of cool to watch. So, I started tearing down the harness tonight. I was getting some weird readings when I was checking the Ohms. It was really dark and the wires hard to decipher but I believe that 4th injector is light blue with pink and I got no reading from computer plug to injector. Now the really odd thing is I put the tester on the 12v injector constant and it started reading but the other lead was still on the blue and pink at the computer plug. So, either I did something wrong or maybe those wires are melted together somewhere. The good news is I just rewired a Ducati and have all sorts of fancy tape, and covers. The bad news is I just freaking had to re-wire a Ducati.

                Comment


                • #9
                  Got it back, plugged everything up. Same thing. Harness has continuity from plug to injector, plug tests fine from front to back. So, what input tells this thing to fire each injector? CPS? Got to be something coming from the input side I would think. Odd though just three and four.

                  Edit: So, I told my wife to get her but in the Jeep, I needed a helper. I pulled the PCM injector plug, stabbed a wire over middle pin number five, hooked my tester lead on the positive cable, connected the two, turned over the Jeep, Walla, we had light! So, I guess my connector is being a but head. Time to pull it apart and re-crimp the little @#$%$%. I bet I could get a touch of conductive grease in there.

                  Comment


                  • #10

                    Comment


                    • #11
                      Oh, I am not sure that is going back together. It kind of just fell apart once I got the back out. The odd thing that I am wondering is, does the computer use different programming to start the Jeep then transfer to something else for running purposes. Wranglerfix is sending me a new plug, even offered to build and send me a new computer to test. The reason I ask the question is I swear that plug was intact as far as connectors. My buddy remembered last night that it was running fine, but dying in weird places. Got a CPS error, so he changed that (Evan brought me the old one), then said it cranked great but quickly started tunning poorly. Being he is cheap he used a cheap CPS sensor. What are the odds? I ordered a well reviewed one online for testing purposes. I also ordered some fantastic bluetooth scanner. Someone was surprised I didn't have one, hell I have never had a TJ run bad.

                      Comment


                      • #12

                        Comment


                        • #13
                          Mama's don't let your babies by CPS sensors from China!

                          So, I managed to put that 32 pin connector back together. Twice actually. Side note, did you know you can but it together upside down! I am a master at that now. Slapped my new well reviewed CPS from Taiwan on it. It rannnn perfect all the way until I went inside and grabbed my hat. As I was walking back out I heard it start sputtering. I said nope. I slapped the known defective buts runs good until hot MOPAR one on it. Cranked and ran crappy. Went inside to do something came back out fired it up to park it on the burn pile and it ran great. Drove it a few miles and I could tell when it got hot and crapped out. Ran like poo and would not re crank. Slapped Taiwan back on and cranked right up and purred like a kitten. Drove it all around the area and perfect. Tried not to restart twice but runs fantastic. Guess who is ordering a Mopar CPS tonight and rewrapping all his wires!

                          Time to order some OD green and a flat fender kit.

                          Comment


                          • #14
                            What a pain!!!! Good job. Mopar for the win!
                            97’ TJ on 37’s with 4 Angry Squirrels
                            2020 F250 Powerstroke Tow Pig

                            Comment


                            • #15

                              Comment

                              Working...
                              X